// 谷村晋 2006年  5月 11日 木曜日 
// 自由に加筆してください

// 2016-12-07 (Wed)
// 現在、Vine LinuxでRのメンテナーをしている荒です。
// 現状に合わせて改変します。

COLOR(red){SIZE(30){[[VineLinux:http://vinelinux.org/]]}}

この頁では[[VineLinux:http://vinelinux.org/]]でRを使うための情報を集積します。

COLOR(#008080){&size(10){VinePlusにRが収録されて記念にこの頁を新規に作成しました。自由に加筆してください};}

----

#contents
----
* [[VineLinux:http://vinelinux.org/]]とは [#p31798ad]
国産のLinuxディストリビューションで、日本環境に定評がある。Vineプロジェクトとそのコミュニティによってメンテナンスされている。[[VineLinux:http://vinelinux.org/]]のインストールCDは1枚だけであり、プラットフォームはPC/AT互換機で動作する。

追加パッケージは、VinePlusと呼ばれるカテゴリーに収録されており、ネットワークインストールで追加インストールすることが出来る。RはVinePlusに収録されている。

* Rのインストール [#td39dc4b]

インターネットに接続された状態で下記のコマンドを実行します。
 # apt-get update
 # apt-get install R

// (以下の内容は古いため削除します:荒)
// もし、下記のようなエラーがでたら、VinePlusが有効になっていません。
//  パッケージリストを読みこんでいます... 完了
//  依存情報ツリーを作成しています... 完了
//  E: パッケージ R が見付かりません
// VinePlus extrasからのインストールを有効にしていない場合は、/etc/apt/sources.listをroot権限で編集して、コンポーネントリストに "extras" を追加して、extrasを有効にします。

//(2009/9/25現在)
// VineLinux4.2/5.0用にR-2.9.2-1vl{4,5}.i386.rpmがアップロードされています。
// 両方ともplusカテゴリなのでextrasを有効にしなくてもインストールできます。

// ** R-2.2.1-0vl1をお使いの方へ [#q0a087ff]
// R- 2.2.1-0vl1のR.specにバグ(%preunタグのエラー)があり、通常の方法ではR-2.2.1-0vl1を正常にアンインストールできません。従って、rpm -Fvhなどでバージョンアップできなくなっています。大変申し訳ありません。お手数で恐縮ですが、一度、

// # rpm -e R  --noscripts

// でR-2.2.1-0vl1をアンインストールしてから新しいバージョンを入れてください。

* Vine Linux 6.5βのR [#w6b1177f]
* Vine Linux 6.5のR [#w6b1177f]

Vine Linux6.5βでは tcl-8.5/tk-8.5 を使用するように変更しています。
Vine Linux6.5では tcl-8.5/tk-8.5 を使用するように変更しています。
これにより R commander を使用することができるようになっています。

Vine Linux 6.3では
 # apt-get install apt-sourceslist-proposed-updates 
 # apt-get update
 # apt-get install R
でインストールできます。
// Vine Linux 6.3では
// # apt-get install apt-sourceslist-proposed-updates 
// # apt-get update
// # apt-get install R
//でインストールできます。

* Rの追加パッケージのインストール [#yec065be]

初めてRをインストールした場合は、baseパッケージしかインストールされていません。Rの追加パッケージはCRANからネットワークインストールします。root権限でRを起動してinstall.packages()を実行します。

 > install.packages("追加したいパッケージ名")

* [[JAGS]]のインストール [#cc9f47f0]

[[JAGS]]をインストールするには下記のようにします。

//  # apt-get install http://shakan2.tm.nagasaki-u.ac.jp/rpm2html/RPMS/i386/jags-0.90-0.i386.rpm
 # apt-get install JAGS


* コメント [#v845a701]
#comment

トップ   編集 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Google
WWW を検索 OKADAJP.ORG を検索